Does Astronomer v0.7 have support for Airflow 1.10?


#1

I’m an Astronomer customer, and would love access to Airflow 1.10 features on Astronomer v0.7.

What do I need to do?


#2

Yes, using airflow 1.10.1 is a simple change.

  1. Upgrade the CLI to the latest version (astro upgrade).

  2. Change the FROM link in your Dockerfile to:

FROM astronomerinc/ap-airflow:0.7.0-1.10.1-onbuild

This will pull down our 1.10.1 image instead of the 1.9 image.
3) Confirm this works by running astro airflow start and you should see the 1.10.1 UI at localhost:8080/admin.

Notice that there’s the little Red X to delete DAGs from the UI, confirming that you are running Airflow 1.10.1 (or go to About -> Version

Note: Astronomer’s 1.10.1 image does not support the Airflow RBAC on v0.7 - this will be a part of our 0.8 release.