Can I not manually trigger a DAG on a deployment that runs on LocalExecutor?

#1

If you have a running Airflow instance on Astronomer using the LocalExecutor (or you’re just fully running it locally) and you try to manually trigger a DAG via the Trigger DAG button on the Airflow UI, you’ll notice that tasks don’t actually get picked up.

Unfortunately, this is expected behavior - the Trigger DAG button actually only works when using the Celery Executor. When you’re developing locally, the Local Executor is used. As a workaround for development, we’d recommend setting the schedule_interval to @once and turning on the DAG to execute it. It will only run one time and if you need to run it again, clearing (not “retry-ing”) all the tasks will cause it to restart.