Command:sudo astro deploy - Error: No context set, have you authenticated to a cluster?

I get “Error: No context set, have you authenticated to a cluster?” when I run command: sudo astro deploy. Please see below:

1. I have 1.10.12 CLI installed in my test environment; also prod is running with this version…
browser: http://localhost:8080/version is below:
output: Astronomer Certified 1.10.12.post3 based on Apache Airflow 1.10.12

2. I successfully authenticate to my workspace:
command: astro auth login
Switched cluster
Username (leave blank for oAuth): <email_address>
Default () workspace found, setting default workspace.
Successfully authenticated to

3. When I check astro version on command line:
command: astro version
output: Astro CLI Version: 0.23.4, Git Commit: 4efb05b0d026e4e5b5420b5729cf9fdb2630e400
Astro Server Version: Please authenticate to a cluster to see server version

4. Checking workspace list (after running bullet point #2 above - successfully authenticated)
command: astro workspace list
output: Error: No context set, have you authenticated to a cluster?
astro workspace list [flags]

Why CLI gets authenticated successfully but Astro server version does not? Does this require a different authentication?
Why I cannot list the workspaces?

PS: I have other developer friend who has a lower version can authenticate successfully and can deploy the project to prod.

Your help is appreciated very much.

Thank you.