Install airflow.operators.*

Hi I’m new to using Airflow 2.0 and Astronomer. I’m testing out the product and running local using the cli. When I try to run basic dags I’m seeing that any operator I try to use isn’t present on the image.
for example:
from airflow.operators.python import PythonOperator
from airflow.operators.dummy import DummyOperator

both throw an error when I load the dag saying those modules (dummy and python) are not installed. I looked through the documentation but I have not seen how to install them… seems pretty basic to not be installed.

Hi there!

Have you tried updating the import statements to the ones below?

`from airflow.operators.python_operator import PythonOperator`
`from airflow.operators.dummy_operator import DummyOperator`

Hi !
I’m with the same issues.
I tried to use airflow.operators.python_operator import PythonOperator and it seemed to work, but something is wrong…
First. The IDE tells me this syntax is deprecated and tells me to use the airflow.operators.python version instead.
Second. I don’t know if it has something with this error, but I can’t import the “kwargs” operators. It brings me a blank variable…
Weird…
Thanks for any help !