Installing Airflow on EKS Fargate

HI All

I have EKS Fargate cluster ver 1.22 on Aws. I am trying to install Airflow on it using

helm upgrade --install airflow apache-airflow/airflow -n dev --values values.yaml --set volumePermissions.enbled=true --debug

The install completes, however the port forwarding command that needs to be executed afterwards fails, also the webserver(and couple of other ones) pod remains in continuous CrashLoopBackoff state:

airflow-scheduler-77fbff86f5-bhkz7 1/3 CrashLoopBackOff 31 (5m10s ago) 105m
airflow-statsd-77bd4f95df-5mh6t 0/1 CrashLoopBackOff 25 (69s ago) 105m
airflow-triggerer-59545ffc87-lp94g 2/2 Running 19 (2m45s ago) 105m
airflow-webserver-69b9554c56-r4d9n 0/1 CrashLoopBackOff 25 (4m18s ago) 105m

Any thoughts on what what could be the issue? The airflow version is 2.4.1


Turns out that i had to specify the requirements

Blockquote resources:
cpu: 500m
memory: 2G
cpu: 500m
memory: 2G
create: false
name: airflow-sa
# arn:aws:iam::564863080376:role/AirflowIamRole
enabled: false