Airflow not running my daily scheduler

The problem is, with a daily based schedule, it doesn’t run at all.
What’s working: */15 * * * *
What’s not working: 1 x * * * * (x can be any hour, in the picture, it’s 17 and 18)
Please ignore the errors in the image.

Airflow setting:

I think it’s because of your start_date is always current time.

Please set it to something in the past and set catchup to false.

I personally do not like dynamic start_date because it doesn’t make any sense logically and it introduces issues like these where the start_date can impede the dagruns from being created.