Cannot start scheduler/webserver with `astro dev start` for an existing project

I am just getting started with the 14-day free trial of Astronomer Cloud today. Very excited. I only get one deployment for the trial, so after running through the quickstart (where running / deploying worked fine), I deleted the demo deployment, and ran astro dev init from within an existing project of mine to really get started.

However, when I run astro dev start from this repository, I’m receiving the following errors when starting the scheduler and webserver.

Perhaps I should instead create a clean/new directory, and copy/paste my existing DAGs into this new directory… and then git init and astro dev init this new directory. However, I would prefer to use my existing directory as it is already setup as a Git repository with history for my airflow project. I’d like to migrate my existing DAGs / directory into Astronomer cleanly, and could use some help with resolving this issue.


Hey @nick- sorry for the delay on this, looks like it got flagged as spam initially for some reason. Can you open a support ticket for this at Since you’re an Astro Cloud user, our support team can dig in here. It looks like you have something going on with your local docker setup.

1 Like