"panic: runtime error" after running astro dev run in init project

I get an issue which I cannot find any information about anywhere on the world wide web.

I’m on Windows. I’m running WSL2, Ubuntu 22.04.3 LTS.

I’m running the latest Docker desktop and Docker engine available (v24.0.6 engine and v4.25.1
I did install the Astro CLI with curl -sSL install.astronomer.io | sudo bash -s
This installed v1.20.1.

I’ve tried two astro-runtimes in the Dockerfile:
FROM quay.io/astronomer/astro-runtime:9.1.0
FROM quay.io/astronomer/astro-runtime:9.5.0

Astro CLI commands works fine, and interacts with Docker (astro dev restart, for example).

Steps to reproduce:

  1. mkdir empty_project
  2. cd empty_project
  3. astro dev init
  4. astro dev start
  5. astro dev run

After running the run command (like connections list or providers list) I get the following error message:

> Running: airflow connections list
> panic: runtime error: invalid memory address or nil pointer dereference
> [signal SIGSEGV: segmentation violation code=0x1 addr=0x28 pc=0x521986]
> goroutine 71 [running]:
> bufio.(*Reader).Read(0x0, {0xc00045e000?, 0xc00038f950?, 0xc000505fb8?})
>         /usr/local/go/src/bufio/bufio.go:216 +0x86
> github.com/docker/docker/pkg/stdcopy.StdCopy({0x172fb00, 0xc000012018}, {0x172fb00, 0xc000012020}, {0x172ce20, 0x0})
>         /go/pkg/mod/github.com/docker/docker@v20.10.7+incompatible/pkg/stdcopy/stdcopy.go:108 +0x444
> github.com/astronomer/astro-cli/docker.ExecPipe.func1()
>         /go/src/github.com/astronomer/astro-cli/docker/docker.go:42 +0x54
> created by github.com/astronomer/astro-cli/docker.ExecPipe
>         /go/src/github.com/astronomer/astro-cli/docker/docker.go:40 +0x1d8

What am I doing wrong here? And I’m saying “I” since I cannot find anyone else with the same issue.

Hi @yeykawb, Welcome to the Astro Community, Glad to see you using the Astro CLI, and Sorry for the issue you are experiencing.

Can you try the solution mentioned in this thread and let us know if this works for you? OS was Ubuntu as well in this case.

Hope this helps!

Akash Laddha

1 Like

Hey Akash,

thanks for this tip - it works now.

1 Like