Airflow UI doen't work on localhost after astro dev start

This used to work, however, now it doesn’t. After successfully running astro init and astro dev start, if I open a browser and try to open http://localhost:8080 it returns this error on Chrome:

This page isn’t working
localhost didn’t send any data.

This error on Safari:

Safari Can’t Open the Page
Safari can’t open the page “‎localhost:8080” because the server unexpectedly dropped the connection. This sometimes occurs when the server is busy. Wait for a few minutes, and then try again.

If I look at Docker Dashboard, I can see the web server and scheduler processes keep restarting every 10 seconds or so. Same thing is reflected in astro dev ps.

Screen Shot 2021-08-04 at 11.03.56 AM


macOS: Big Sur 11.5 (20G71)
Astro CLI Version: 0.25.1, Git Commit: ab3af105f967105fa23e6c317c474612803b21e2
Docker Desktop: Version 3.5.2 (
Docker Engine: v20.10.7

  "experimental": false,
  "features": {
    "buildkit": false
  "builder": {
    "gc": {
      "enabled": true,
      "defaultKeepStorage": "20GB"
  "debug": true

On Mac, make sure that your docker engine has had enough memory allocated to it. The default memory allowance is too low to reliably start up astro.

Try checking the logs of each of the 3 containers in docker. I had a similar issue and the postgres container was failing to start because the port was already in use.

I had this same issue and was able to resolve it by cleaning/purging data from docker.

Open docker > click on the icon beside the gear icon > clean/purge data

Then rerun astro dev start and give localhost:8080 another try