Astro Dev Start Error - client version 1,20 is too old?

Not sure what happened as I’ve been using astro cli locally for a couple of months without problems. I think the problem started with an update to Docker a few days ago.

Regardless, when I try to run “astro dev start” for my project, I get the message:

astro dev start
Env file “.env” found. Loading…
Error: Error checking docker-compose status: Error response from daemon: client version 1.20 is too old. Minimum supported API version is 1.24, please upgrade your client to a newer version

Please let me know if you’ve seen this before or have any suggestions.

I’m unclear why, but this stopped happening when I ran “astro dev start” this morning. I’m unaware of anything I did or anything that changed. In any case, please disregard.

Hey @MarkEvansHW ! Thanks for reporting this issue, and sorry to hear you ran into it. We had another customer report this exact error a few months ago and similarly said it was resolved without doing anything.

Are you running on Windows?

In any case, glad to hear you’re back up and running - don’t hesitate to reach back out if it comes up again.