Astro dev start error

I’m following the certification preparation course. Running astro dev start results in this error:

Env file ".env" found. Loading...
buildkit not supported by daemon
Error: command 'docker build -t astro_d7eada/airflow:latest failed: failed to execute cmd: exit status 1

My setup:

  • macOS Big Sur version 11.2.3 (20D91)
  • zsh 5.8 (x86_64-apple-darwin20.0)
  • Docker Desktop version 3.3.1 (63152)
    • Engine 20.10.5
    • Compose 1.29.0
    • Kubernetes v1.19.7
    • Notary 0.6.1
    • Credential Helper 0.6.3
    • Snyk v1.461.0

Never mind. I found there’s another post which talks about this. Since I have Docker Desktop for macOS installed, this worked for me.

Before

{
  "debug": true,
  "experimental": false
}

After

{
  "debug": true,
  "experimental": false,
  "features": {
    "buildkit": false
  }
}

Yup, this will do it! Thanks for the update @ejstembler and glad you got it running. We’re working on a long-term fix for buildkit support :slight_smile:

@paola, Is there a Windows equivalent of this? Making the same edits in windows-daemon-options.json did not help.

Hi @demyan ! Sorry you’re running into this. A few things:

  • Are you running Docker Desktop on Windows? If you go to Preferences > Docker Engine, you should still be able to configure that file.
  • If that doesn’t work, try running DOCKER_BUILDKIT=0 astro dev start or set that as an env in your Dockerfile. I’m not running on Windows myself, but that may do the trick.
  • If you’re still seeing errors, can you specify the following:
    • Are you seeing this exact buildkit error, or something else?
    • Version of the Astro CLI
    • How exactly are you running the Astro CLI on Windows? WSL2? We have a doc with more info here.

For reference, there’s another forum post here on this: 'buildkit not supported by daemon Error: command 'docker build -t airflow-astro_bcb837/airflow:latest failed: failed to execute cmd: exit status 1

Thank you, @paola. The very first bullet point helped. Editing windows-daemon-options.json earlier did not seem to change the setting.

1 Like

Great, glad you got it worked out @demyan !

1 Like