'buildkit not supported by daemon Error: command 'docker build -t airflow-astro_bcb837/airflow:latest failed: failed to execute cmd: exit status 1

If you’re running the Astronomer CLI with the buildkit feature enabled in Docker, you may see this error on running $ astro dev start:

Env file “.env” found. Loading…
buildkit not supported by daemon
Error: command 'docker build -t airflow-astro_bcb837/airflow:latest failed: failed to execute cmd: exit status 1…

If you see this, check 2 things:

  1. Is buildkit support turned on in your daemon.json file (/etc/docker/daemon.json)? If so, you’ll see something like:
{
  "experimental": false,
  "features": {
    "buildkit": true
  }
}
  • Set "buildkit" to false and restart Docker.
  1. Is buildkit support turned on by an environment variable?
    • Check to see if the DOCKER_BUILDKIT env variable is set to 1.
    • If yes, set to 0 and restart Docker.

That should do the trick. If the problem persists, don’t hesitate to reach out to Astronomer Support.

6 Likes

Ran the command DOCKER_BUILDKIT=0 astro dev start and it worked.

11 Likes

For Mac User, you can edit it as follow:

Go to Taskbar -> Docker Icon -> Preferences -> Docker Engine and update your configuration file

6 Likes

This is the Docker Engine config that worked for me on Docker Desktop for Mac:

{
  "experimental": false,
  "features": {
    "buildkit": false
  }
}
5 Likes

Thanks for this update! This worked for me as well.

1 Like

Same we can do if we have installed docker in Windows as well.