Astronomer/astro-cli: platform darwin/arm64 is not supported

I tried to install astronomer via cli but i receive this message:

astronomer/astro-cli: platform darwin/arm64 is not supported. Make sure this script is up-to-date and file request at

Somebody know how install successfully astronomer in MAC M1?

Well, I was finally able to install astronomer but it was through brew and specifying the architecture with the following command.

arch -arm64 brew install astronomer/tap/astro@0.16.4

@joaquin-casanova , i’m having the same problem on installing astro on M1. I tried the command you mentioned but it didn’t work for me. Here’s the error:

==> Tapping astronomer/tap
Cloning into '/opt/homebrew/Library/Taps/astronomer/homebrew-tap'...
remote: Enumerating objects: 306, done.
remote: Counting objects: 100% (120/120), done.
remote: Compressing objects: 100% (100/100), done.
remote: Total 306 (delta 52), reused 45 (delta 20), pack-reused 186
Receiving objects: 100% (306/306), 49.60 KiB | 393.00 KiB/s, done.
Resolving deltas: 100% (136/136), done.
Error: Invalid formula: /opt/homebrew/Library/Taps/astronomer/homebrew-tap/Formula/astro.rb
formulae require at least a URL
Error: Invalid formula: /opt/homebrew/Library/Taps/astronomer/homebrew-tap/Formula/astro@0.25.1.rb
formulae require at least a URL
Error: Cannot tap astronomer/tap: invalid syntax in tap!
1 Like

Installation under -arm64 not worked for me, however installation under -x86_64 from this answer worked.

Also, -x86_64 approach is within official docs already. See: CLI QuickstartStep 1: Install the Astronomer CLIInstall the CLI on Apple M1 Machines, link.

1 Like