Astronomer CLI Not Able To Use Local Image

I’m trying to use an image I’ve built locally with Docker when using the KubernetesPodOperator, but it does not seem to be working. I can see the image when I run docker images but it looks like the Astronomer CLI is by default checking DockerHub. Is there any way to have it check my local images? Or is the only way to run a local registry?

Which cluster do you use? Can you share the kubernetesPodOp task (code) ?

To pull image locally change to a tag other than latest.
This is happening because the latest tag sets the imagePullPolicy to Always implicitly. You can try setting it to IfNotPresent Or Never