Create User doesn't work

I’m working on Enterprise ed. of Astronomer. I want to create users on specified Workspaces using Astro CLI. But unfortunately, after typing the command

astro user create

and entering email address and password, I receive:

Error: Cannot read property 'errors' of undefined

I don’t know why I can’t make a new user. I’m using astro CLI v0.9.1 but I checked also v0.9.5 and I see the same error.

Hi, sorry your having an issue with the CLI. So you are using Astronomer Enterprise edition? What version is installed on your cluster? It may be that your cluster is still on v8. If that is the case, please try downgrading your cli version to match your cluster version.

Here is the command to rollback to the v8 version of the cli
curl -sSL | sudo bash -s -- v0.8.2

Hi @AndrewHarmon
Our Astronomer instance has v0.9.2. in spite of that, I’ve checked to create a user by astro CLI v0.8.2. Regrettably, the same error.
Any advice?

Hi @konik44 - Jumping in here! It does look like we disabled that configuration by default (localEnabled) in our latest release, as we’d rather most folks go through the Auth0 route.

If you’d like to enable user creation from the CLI to true, you’re free to do so within your own installation of Astronomer Enterprise.

        enabled: true

As for the error itself, we totally acknowledge it should be clearer. We just pushed up a change yesterday for that error to instead read User creation is disabled that you’ll see in our next patch release (Astro v0.9.6).