Failure in name resolution (github action)


We try to run integration test in github actions with docker.
We deploy a FTP container, a S3 container and a local database to simulate our pipeline and we deploy astronomer via the astro deploy CMD and the latest dockerfile.
When the DAG executes the code to get the files on the FTP server, we get this error :

Failed to execute job 4 for task plant_from_ftp_to_s3 ([Errno -3] Temporary failure in name resolution; 575)

When we launch the same test in local, we don’t get this error.
We tried to connect all the containers to the same network interface but we had the same result.
We also tried to modify the astronomer’s host file but had the same result.
Do you have an idea about what prevents the connection between the containers ?

It sounds like you are not able to resolve DNS in Github Actions.

Can you show:

  • the method you are using to deploy and run the containers for CICD (docker-compose?)
  • How the DAG is attempting to connect to the FTP server, and if possible what the FTP Connection hostname is for CICD? Can you also verify that if you are using an Airflow connection, that it exists in the CICD environment?
  • Where is Airflow that you are running exist? In Astro? Or in Docker in Github Actions?
  • Can you clarify what you mean by “astronomer’s host file”

Hi and thanks for your reply.
We have solved the issue : the astronomer containers and the other ones were not able to communicate inside the default network.We created a new network and connected all the containers so that the astro web server could connect to the ftp-server with its service 's name.
The FTP server is a simulation of an external application providing input files.
Airflow is running with the astro dev start command, so it’s in several docker containers.
When i was talking about astronomer’s host file, i meant the astro webserver host file (in /etc)

I think we can tag this topic as resolved