Docker push failure

I’m trying to push my astronomer code to Astronomers docker registry but am getting a failure. I’ve created a service account with Admin privileges and logged in successfully. I am getting the error “Retrying in X seconds” over and over and then after about 30 seconds the command fails with

received unexpected HTTP status: 500 Internal Server Error

Hi @ron! Thanks for posting in here and glad to see you getting started on Astronomer Cloud. A few things here:

  1. Can I ask what the nowledge-153 is in the command you posted? Can you try replacing that with your full release name in the format of spaceword-spaceword-xxxx? So for example: docker push You can find this release name in the Settings page of the Astronomer UI.

  2. Can you verify the version of the Astronomer CLI that you’re running? To check, you can run $ astro version. As long as you’re running v0.23+, you should be ok. Refer to CLI Quickstart for more info.

  3. Did you authenticate to your Airflow Deployment on Astronomer Cloud before running this command, and did you verify you have the right permissions to push code to that Deployment (i.e. Deployment Admin)?

Try verifying the above and let us know if you’re still running into trouble - we’re here to help.

Hello @paola - Thank you for getting back to me. I realized I had totally jumped the gun and was attempting to run the commands in the CI/CD Tutorial before doing a basic deployment. After I ran the basic deployment it worked totally fine. Thanks for responding and we can close this case.

1 Like

Oh, great @ron! Glad you got this resolved and you’re very welcome. Don’t hesitate to submit another post or reach out to Astronomer Support if you run into trouble with anything else.