Manually running a DAG but doesn't seem to work

I’ve gone through the Quickstart ( tutorial and was trying to run the example DAG but haven’t been able to get it working. To run it, I simply click the Play button underneath Actions on the front page. I updated the schedule_interval parameter to be just 2 minutes but left the start_date parameter as start_date=datetime(2019, 1, 1)
However, I can’t seem to get the DAG to properly run. It seems to be in a perpetual state of Running.

Am I missing something? How do I get this to run?

Hi @bkim,

Is the DAG paused? By default, new DAGs are set to paused initially and need to be manually unpaused with the toggle switch on the left side of the DAG entry in the Airflow UI.

1 Like

Ah yeah that was it. Thanks!