Astro cli not installing

My Environment: macOS Catalina with the standard terminal.

Running through the CLI Quickstart and not able to get the very first command (curl -sSL https://install.astronomer.io | sudo bash) to execute.

When I test it with the astro command nothing happens in my terminal.

Steps I’ve tried:

  1. Saving the curl’d file to an .sh file locally and executing with sudo bash --> then executing the test astro command yields nothing.
  2. Downloaded and executed the https://raw.githubusercontent.com/astronomerio/astro-cli/master/godownloader.sh file with sudo bash and got the following output:
astronomer/astro-cli: checking GitHub for latest tag
astronomer/astro-cli: found version: 0.12.0 for v0.12.0/darwin/amd64
astronomer/astro-cli: downloading https://github.com/astronomer/astro-cli/releases/download/v0.12.0/astro_0.12.0_darwin_amd64.tar.gz
astronomer/astro-cli: downloading https://github.com/astronomer/astro-cli/releases/download/v0.12.0/astro_0.12.0_checksums.txt
astronomer/astro-cli: verifying checksums
astronomer/astro-cli: installed as ./bin/astro

But the astro command yields the following:

zsh: command not found: astro

so I executed with sudo astro and yield the following:

sudo: astro: command not found

Also I see nothing in my bin dir…

Would love any tips/help?

Hey @bambooJon! Can you try running ~bin/astro and which astro and let me know what you see?

My Coworker also isn’t able to get that first command from the CLI Quickstart to execute either curl -sSL https://install.astronomer.io | sudo bash.

which astro yields astro not found

Can you try running the install command with parenthesis around it? I think there may be something funky with how zsh handles the | character.

ie.

(curl -sSL https://install.astronomer.io | sudo bash)

No dice… :frowning:

One more- thanks for bearing with me!

Give this a shot:
curl -sSL https://install.astronomer.io | sudo bash -s < /dev/null

That gave me the following:

zsh: command not found: astro

:frowning:

Sorry to hear it! And did you ever give ~/bin/astro a shot?

I did. Nothing is created in the bin.

I think something is wrong in the script which pulls down the .sh script. Especially, because my coworker had the same issue on his non-linux machine.

Also, there seems to be something in the script not working for macOS… but it does for linux.

@pete, any update from you/your CLI team on this?

I eventually had success in Ubuntu 18.04 by circumventing the https://install.astronomer.io script altogether and instead just brute forced it with:

wget --no-check-certificate "https://raw.githubusercontent.com/astronomerio/astro-cli/master/godownloader.sh"

followed by

bash godownloader.sh

After that, I was able to astro dev init and astro dev start successfully.

Not sure how helpful that is, but that’s what worked for me.