CLI Error: `Warning: failed to get default registry endpoint from daemon`

#1

If you’re setting up the Astro CLI, you might see the error below upon trying to auth in:

Warning: failed to get default registry endpoint from daemon (Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?). Using system default: https://index.docker.io/v1/
Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?
Failed to authenticate to the registry, this can occur when registry is offline. Until authenticated you will not be able to push new images to your Airflow clusters

From there, you might get the error below after running astro airflow start:

Error: Error checking docker-compose status: Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?

That error suggests that Docker isn’t running on your machine. To check, run docker ls - sometimes it doesn’t start up by default.

If you don’t have it running, try running sudo systemctl start docker.