Error on Deploy: `Error: command 'docker push [...] cli-1' failed: denied: You do not have permission to manage..."

If you’re trying to deploy to Astronomer Cloud or Enterprise (whether via the CLI or CI/CD), you might get an error akin to:

Error: command 'docker push' failed: denied: You do not have permission to manage geosynchronous-cosmos-6014

This error indicates that, as a user, you don’t have the permissions you need to push code to that deployment on Astronomer.


To successfully deploy, you’ll need to make sure you’re an “Admin” or “Editor” on your Astronomer Workspace (not a “Viewer”, which is the default).

  • Navigate to the Astronomer UI to verify who on your team is listed as an “Admin” in the Workspace (and that the deployment you’re pushing code to is in that Workspace)
  • Ask an “Admin” to give you either “Admin” or “Editor” access

Note: For an overview of permission sets and our role-based access control functionality, refer to this doc. If you’re an Astronomer Enterprise user, you may be able to configure the roles themselves. Reach out to our Support Team for assistance.

Can login to registry:

docker login -u _ --password-stdin < …/my_password2.txt

Login Succeeded

But why cannot push after build?

—> Using cache
—> Using cache
—> 58f1e89351d0
Successfully built 58f1e89351d0
Successfully tagged universal-perigee-6050/airflow:latest
Pushing image to Astronomer registry
The push refers to repository []
Error: command ‘docker push’ failed: Get EOF