Installing Astro

Hello, I am a recent data science grauduate from Lighthouse labs and recently attended the Toronto Modern Data Stack meetup.

I installed astro using winget install -e --id Astronomer.Astro -v 1.18.2 and the output is:

PS C:\WINDOWS\system32> winget install -e --id Astronomer.Astro -v 1.18.2
Found Astro CLI [Astronomer.Astro] Version 1.18.2
This application is licensed to you by its owner.
Microsoft is not responsible for, nor does it grant any licenses to, third-party packages.
██████████████████████████████ 28.9 MB / 28.9 MB
Successfully verified installer hash
Starting package install…
Command line alias added: “astro”
Path environment variable modified; restart your shell to use the new value.
Successfully installed

However I am having issues with running “astro version” in my powershell. I am following this guide: Install the Astro CLI | Astronomer Documentation

the error I am getting is this:
astro : The term ‘astro’ is not recognized as the name of a cmdlet, function, script file, or operable program. Check
the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:1

  • astro version
  •   + CategoryInfo          : ObjectNotFound: (astro:String) [], CommandNotFoundException
      + FullyQualifiedErrorId : CommandNotFoundException

I hope to get some support on this. TIA!

Hey @nasserothman! Welcome to Astro, super cool that you went to the Toronto Modern Data Stack meetup with us.

Looks like the issue you’re seeing is specific to Windows and related to the name of your file. Could you try renaming your file to astro instead of astro.exe and see if that does it?

Hi @paola ! I’m looking forward to the next one!

So I went into the file and changed it from astro.exe to astro then I opened powershell and ran “astro version”. I get the same error when I run the same code and changing the file back to “astro.exe”. This is what error I am seeing:

PS C:\Users\nas76\AppData\Local\Microsoft\WinGet\Packages\Astronomer.Astro_Microsoft.Winget.Source_8wekyb3d8bbwe> astro version
Program ‘astro.exe’ failed to run: No application is associated with the specified file for this operationAt line:1

  • astro version

At line:1 char:1

  • astro version
  •   + CategoryInfo          : ResourceUnavailable: (:) [], ApplicationFailedException
      + FullyQualifiedErrorId : NativeCommandFailedcd

Hm. Let’s do this…

  1. You could try to just install the CLI manually without using winget. You’ll have to go into our GitHub repo and download a package based on your machine architecture. But it should work. Docs here.

  2. We can keep troubleshooting winget.

    • If you install another package on winget, does that work properly?
    • Can you check if you’ve set up your path correctly such that winget packages are recognised?
    • What version and architecture of Windows are you using?

Let me know if that works. If it doesn’t, then I’d say either go ahead and email our support team ( or you can reach out to me directly ( and we can sort you out offline!