See no web ui when following quickstart guide

Trying to follow the quickstart guide to the step of astro dev start.

I can’t see the web UI on port 8080 properly.

Have no idea how to further debug this problem. ;-(
Would appreciate any help to unblock the current situation. Thanks in advance.

My trace:

» astro dev start                                            
Error checking feature flag no context set, have you authenticated to a cluster
Error checking feature flag no context set, have you authenticated to a cluster
Sending build context to Docker daemon  10.24kB
Step 1/1 : FROM quay.io/astronomer/ap-airflow:2.2.3-onbuild
# Executing 7 build triggers
 ---> Using cache
 ---> Using cache
 ---> Using cache
 ---> Using cache
 ---> Using cache
 ---> Using cache
 ---> Using cache
 ---> 55290f8b0e56
Successfully built 55290f8b0e56
Successfully tagged quickstart_fa962c/airflow:latest

Use 'docker scan' to run Snyk tests against images to find vulnerabilities and learn how to fix them
Creating network "quickstartfa962c_airflow" with driver "bridge"
Creating volume "quickstartfa962c_postgres_data" with driver "local"
Creating volume "quickstartfa962c_airflow_logs" with driver "local"
Airflow Webserver: http://localhost:8080
Postgres Database: localhost:5432/postgres
The default credentials are admin:admin
» docker ps                                                  
CONTAINER ID   IMAGE                              COMMAND                  CREATED         STATUS         PORTS                    NAMES
bb586a942508   quickstart_fa962c/airflow:latest   "/entrypoint bash -c…"   8 minutes ago   Up 8 minutes   0.0.0.0:8080->8080/tcp   quickstartfa962c_webserver_1
63e8b512fa17   quickstart_fa962c/airflow:latest   "/entrypoint bash -c…"   8 minutes ago   Up 8 minutes                            quickstartfa962c_scheduler_1
7b1db07b09e5   postgres:12.2                      "docker-entrypoint.s…"   8 minutes ago   Up 8 minutes   0.0.0.0:5432->5432/tcp   quickstartfa962c_postgres_1
» curl http://localhost:8080                             
curl: (52) Empty reply from server

» astro version                                              
Error checking feature flag no context set, have you authenticated to a cluster
Error checking feature flag no context set, have you authenticated to a cluster
Astro CLI Version: 0.27.0, Git Commit: 545e76ce1480535561755d97f82c0bf37bbd014f
Astro Server Version: Please authenticate to a cluster to see server version

My setup is MacOS 12.0.1 with Docker Desktop 4.3.1.

Tried troubleshooting suggestions of earlier similar posts regarding Docker engine, but still not working.

My Docker resources settings allocate 9GB memory by default, all 3 airflow related containers run stable, no the issue of container keep restarting.

Also tried “Clean / Purge data” of docker engine, and no use.

Try running docker logs <container id> on the webserver and scheduler container to get more information on why the webserver is not healthy.

» docker logs quickstartfa962c_webserver_1
Waiting for host: 0.0.0.0 5432

» docker logs quickstartfa962c_scheduler_1
Waiting for host: 0.0.0.0 5432

» docker logs quickstartfa962c_postgres_1
...
2021-12-22 06:22:08.248 UTC [1] LOG:  starting PostgreSQL 12.2 (Debian 12.2-2.pgdg100+1) on x86_64-pc-linux-gnu, compiled by gcc (Debian 8.3.0-6) 8.3.0, 64-bit
2021-12-22 06:22:08.248 UTC [1] LOG:  listening on IPv4 address "0.0.0.0", port 5432
2021-12-22 06:22:08.248 UTC [1] LOG:  listening on IPv6 address "::", port 5432
2021-12-22 06:22:08.252 UTC [1] LOG:  listening on Unix socket "/var/run/postgresql/.s.PGSQL.5432"
2021-12-22 06:22:08.263 UTC [57] LOG:  database system was shut down at 2021-12-22 06:22:08 UTC
2021-12-22 06:22:08.270 UTC [1] LOG:  database system is ready to accept connections

Verified via psql that I can login to the postgresql container at localhost:5432.

Any option that I can bump up the logging level of the webserver and scheduler container?

1 Like

I have the exact same problem with Mac 12.0 and Docker 4.3.2.
Did you managed to workaround it?
@zhangcheng

Could you try upgrading your astro cli to 0.27.1, deleting your ~/.astro/config.yaml and then doing astro dev stop && astro dev start from your project folder?

1 Like

Upgraded astro cli to 0.27.1, deleted ~/.astro/config.yaml, did astro dev stop && astro dev start, still same problem as above.
The newly created config.yaml is identical to the one created by 0.27.0.
@rbankston

Not yet, no clue either.

I think I found out why.
The address for Postgres container of 0.0.0.0:5432 is not accessible by both webserver and scheduler container.

astro@66e5853cd8bf:/usr/local/airflow$ nc -v 0.0.0.0 5432
nc: connect to 0.0.0.0 port 5432 (tcp) failed: Connection refused
astro@66e5853cd8bf:/usr/local/airflow$ nc -v 192.168.3.141 5432
Connection to 192.168.3.141 5432 port [tcp/postgresql] succeeded!

where 192.168.3.141 is the ip of my mac.

--- config.yaml.old	2022-01-01 23:09:40.000000000 +0800
+++ config.yaml	2022-01-01 23:45:53.000000000 +0800
@@ -7,7 +7,7 @@
 container:
   engine: docker
 postgres:
-  host: 0.0.0.0
+  host: 192.168.3.141
   password: postgres
   port: "5432"
   user: postgres

so after I change the config.yaml as above, I can now open the web UI.

I faced the same problem on the same version of astro CLI (0.27.0) on Mac OS and upgrade to 0.27.1 helped me. The address for postgres container in config.yaml was changed from “0.0.0.0” to “postgres”:

--- a/config.yaml
+++ b/config.yaml
@@ -7,7 +7,7 @@ cloud:
 container:
   engine: docker
 postgres:
-  host: 0.0.0.0
+  host: postgres
   password: postgres
   port: "5432"
   user: postgres

Thank you :slight_smile: