M1 Chip -- Installation with Rosetta

Hey there,

I’m on a mac with an M1 chip and due to issues with other applications I changed my terminal to always open with Rosetta, installed Homebrew and other packages as if I was on an intel chip, and I haven’t had any issues.

I tried to do the same with Astronomer and the installation was fine, airflow started running, containers were created, and everything looked good until I tried to access the UI for the local project and got a blank error page. Same thing for the Postgres database.

Has anyone else with a similar setup been able to get this to work with a similar setup? Many thanks!

Hi there @bobbyb ! Thanks for reaching out - sorry to hear you’re running into trouble here. Can you share a bit more?

  • Were you able to run astro dev start without an error?
  • Did you try refreshing that Airflow UI page at localhost:8080?
  • What error did you see there exactly?

The Airflow UI (powered by Airflow’s webserver) typically takes a few minutes to spin up. We’re working on a better feedback mechanism there.

In the meantime, send over more detail if you’re still seeing this and we’ll get to the bottom of it.